Авг
8
2014

В Internet Explorer отключат старые ActiveX-элементы

Вчера компания Microsoft сообщила о планах улучшить безопасность своего браузера, путем отключения устаревших элементов управления ActiveX, начиная со старых версий Java.

В официальном блоге разработчиков браузера Internet Explorer появилась запись о важном обновлении для обозревателя, после которого будут блокироваться устаревшие элементы управления ActiveX. Обновление прибудет в следующий вторник, когда начнется ежемесячное обновление продуктов компании.

Функция получила название Out-of-date ActiveX control blocking. Она позволяет предотвращать выполнение страниц, использующих устаревшие ActiveX-элементы. Помимо этого, функция будет отслеживать выход новых версий плагинов и блокировать устаревшие. Что касается поддерживаемых конфигураций, то The out-of-date ActiveX control blocking будет доступен для версий Internet Explorer с 8 по 11, на операционных системах Windows, начиная с Windows 7 SP1. Блокировки удастся избежать зоне интранета (Local Intranet Zone) и доверенной зоне (Trusted Sites Zone), с целью уменьшения проблем для корпоративных пользователей.

В случае срабатывания функции, когда происходит блокировка старых ActiveX, пользователь получит уведомление, вид которых будет зависеть от версии браузера, но похож на представленный ниже. Из уведомления можно обновить заблокированный элемент, нажав на соответствующую кнопку или же запустить в этот раз, для одновременного использования.

Блокировка старых ActiveX в Internet Explorer

Для работы функции будет использоваться специальный файл versionlist.xml, куда будет выгружаться информация об ActiveX, которые должны быть остановлены. Первыми записями там станут старые версии плагина Java, в дальнейшем список будет пополняться. По состоянию на 12 августа (день старта обновлений), в списке будет содержаться информация о следующих версиях Java:

J2SE 1.4 и все ниже, но не включая обновление 43
J2SE 5.0 и все ниже, но не включая обновление 71
Java SE 6 и все ниже, но не включая обновление 81
Java SE 7 и все ниже, но не включая обновление 65
Java SE 8 и все ниже, но не включая обновление 11.

Оставить комментарий

Цитировать